Tutoriel – Utiliser le générateur de cours interactifs eXe Learning

Information

  • Auteur : Philippe Dessus, LaRAC & Inspé, Univ. Grenoble Alpes.
  • Date de création : Septembre 2015.
  • Date de modification : 08 octobre 2020.
  • Statut : Terminé.
  • Résumé : Ce tutoriel présente rapidement le logiciel de création de cours interactifs eXe Learning.
  • Voir aussi : Document Ressources – Générateurs de cours interactifs.
  • Licence : Document placé sous licence Creative Commons : BY-NC-SA.

Site de téléchargement du logiciel

Le site d’eXe Learning est http://exelearning.net/, et on peut télécharger la version 2.5 pour divers systèmes d’exploitation (Windows, OS X, Linux) ici : http://exelearning.net/

Introduction

Il est conseillé de suivre pas à pas la procédure ci-dessous, afin de prendre progressivement connaissance des possibilités de travail d’eXe Learning. Cette procédure comprend deux étapes :

  1. Visionnement de quelques réalisations, afin de comprendre la logique du logiciel ; de ce qu’il permet de faire ou de ne pas faire : dont http://perso.numericable.com/annick.pradeau/ViolenceConjugale/index.html (en chercher d’autres sur Internet)
  2. Lecture attentive de la documentation en français (Le Clainche, 2010), accessible à http://formatice.org/telechargement/exe/guide_utilisateur.pdf (la page du logiciel sur l’excellent EduTech Wiki pourra aussi aider. Les récentes version d’eXeLearning contiennent une aide en ligne en anglais claire et exhaustive (menu Aide>Manuel eXe).

Tutoriel d’initiation à eXe-Learning

Imaginons que vous ayez besoin de faire travailler à vos élèves la question de l’expansion religieuse de l’Occident, au début du millénaire précédent. Vous pouvez d’une part créer une activité de lecture pour l’élève, et un test de closure lui permettant de vérifier ses connaissances sur le sujet.

Voici en 6 étapes le déroulement de la création d’un tel document sous eXeLearning (compatible avec la version 2.4.2, mais montrant des copies d’écran d’une version plus ancienne, en anglais). On pourra consulter cette documentation complète en français (Le Clainche, 2010) pour plus d’informations.

1. Création d’une page de contenu

Pour changer la langue des menus : Outils>Préférences->Choisissez une langue : fr : Français.

Faire un double clic sur “Titre de séquence” dans la zone “Plan” (Outline sur la figure) pour la renommer “Histoire” (le thème général du cours). Cliquer ensuite sur “Ajouter une Page” juste au dessus de la zone “Plan”, on ajoute autant de pages ou sous-pages que l’on veut dans le plan (fenêtre en haut à gauche).

Ajoutons une page intitulée “L’expansion religieuse de l’occident”. Nous nous arrêtons là, mais il est possible de créer une véritable hiérarchie de contenus, avec des sections de niveaux différents, en ajoutant des pages, en en sélectionnant une et en cliquant sur les triangles (pour les faire remonter/descendre dans le plan) et sur les flèches courbes (pour les changer de niveau).

Ensuite, on ajoute un “Outil pédagogique” (zone en bas à gauche) en cliquant sur “Activité de lecture”.

_images/exe-1.jpg

2. Ecriture de la page de contenu

La fenêtre ci-dessous apparaît. Elle est divisée en trois champs, permettant d’entrer du texte, de le formater avec les outils classiques de traitement de texte, et également d’autres types de formats (vidéos, formules mathématiques, tableaux, liens hypertextes internes ou externes, etc.)

  • Le champ du haut permet d’entrer la consigne avant lecture.
  • Le champ du milieu permet d’entrer le texte à lire.
  • Le champ du bas contient une consigne après lecture.

Un clic sur le “v” vert en bas permet de valider le contenu de la page et de passer en mode lecture.

_images/exe-2.jpg

3. Visualisation de la page telle qu’elle serait lue par un élève

À tout moment, on peut vérifier l’allure et le comportement des éléments ajoutés. Un clic sur l’icone “crayon avec trois points” permet d’éditer à nouveau l’élément de contenu sélectionné dans le champ en haut à gauche (revenir à l’étape 2).

Si l’aspect de la présentation ne vous plaît pas, il est possible de changer l’aspect des pages (icones, code de couleur) en choisissant un style différent (menu Styles).

_images/exe-3.jpg

4. Création d’un test de closure

Le même type d’éditeur de textes que celui présenté à l’étape 2 permet de créer un texte de closure, c’est-à-dire un outil “Remplir les blancs”, selon la terminologie du logiciel. L’élève doit compléter un texte caviardé avec les mots appropriés. Ici, nous avons simplement repris le début du texte du cours.

Sélectionner un mot ou groupe de mots et cliquer sur le bouton approprié “Cacher/montrer le mot” permet de signaler les mots qui apparaîtront comme trous dans le texte lu par l’élève.

Ensuite, cliquer sur l’icone “v” vert amène la visualisation de l’activité, telle qu’elle serait lue par un élève (voir figure ci-dessous). On peut voir les trous, qui sont des champs de texte que l’élève doit remplir.

_images/exe-4.jpg

5. Vérification automatique

Si l’élève saisit un mot erroné, le champ se colore en rouge. Il est possible, pour chaque réponse, de faire afficher celle correcte (clic sur le bouton “Montrer les réponses”). Un score s’affiche en bas.

_images/exe-5.jpg

6. Ajout de “Learningapps”

Si l’on trouve que les activités proposées dans eXe Learning sont trop réduites, il est assez aisé d’insérer, dans un document eXe Learning, une applet Java récupérée sur internet, ou bien récupérée ou créée via `learningapps.org<https://learningapps.org>`_. Dans ce dernier cas, il suffit de copier le code de l’applet (disponible pour chaque app dans le champ “intégrer”), et :

  • d’insérer une activité “Applet Java” à l’endroit voulu du cours ;
  • de coller le code de l’applet dans le champ “Code de l’applet” ;
  • cliquer sur l’icone de validation (V) affichera l’applet intégrée dans le cours.

6. Exportation du contenu dans un fichier lisible par un navigateur

Pour exporter les pages créées dans des fichiers HMTL lisibles sur n’importe quel navigateur : Fichier -> Exportation -> Site Web -> Fichier compressé zip. Donnez un nom au fichier, cliquer sur OK. Un fichier Zip (données compressées) est créé. Il se décompresse en un dossier contenant l’ensemble des pages générant le site que vous venez de créer.

Le fichier de départ est index.html.Si vous ouvrez ce fichier dans un navigateur, l’activité va s’ouvrir telle que vous l’avez créée (mais sans possibilité de la modifier) et l’élève va pouvoir la réaliser (en local, les fichiers étant sur le disque dur de l’ordinateur). Il est également possible, si vous disposez d’un accès à un site internet, de télécharger ce dossier et de pointer sur le fichier index.html, afin que tout élève puisse, à distance cette fois, travailler sur l’exercice.

Types d’activités possibles avec eXe Learning

Très succinctement, voici ci-dessous une description des autres activités possibles, classées par thème. Il est conseillé de les essayer pour comprendre leur fonctionnement, et de visualiser ce que verra l’élève. Les documents en références présentent plus en détail ces activités. Cela sort du propos de ce document de présenter plus en détail les nombreuses fonctionnalités d’eXeLearning (toujours aisées à comprendre et manipuler) (cf. Informations complémentaires en référence). Pour les plus avancés, il est aussi possible d’éditer de nouveaux iDevices pour répondre à des besoins particuliers (enchaînements de tâches, etc.).

  • Description de tâches, objectifs et pré-requis : Objectifs, Pré-requis, Activité, Etude de cas, Texte libre.
  • Médias particuliers : Applet Java (pour insérer un programme extérieur), Galerie d’images, loupe sur image.
  • Activité d’évaluation de la compréhension : “Remplir les blancs” (closure), Choix multiple, Exercice “vrai ou faux”, Quiz SCORM (donnant une note finale), Sélection multiple
  • Références extérieures : Site web externe, Article wiki, Flux RSS. Ces trois éléments s’afficheront dans eXeLearning.
  • Mémory (formation de paires).
  • Jeu du pendu

Documentation

Les documents suivants permettent d’en comprendre le fonctionnement :

Le cours suivant (créé par des étudiants de promotions du MARDIF-CNED) permettra de mieux comprendre ce qui est attendu du cours (volet MARDIF) :

Pour aller plus loin